Problema severo con parcho ArcGIS Pro 2.2

Esri ha descubierto un problema severo con el flujo de trabajo en ArcGIS Pro 2.2 Patch2(2.2.2) que puede establecer incorrectamente los valores de los campos de atributos en “Null” y recomendamos encarecidamente que se desinstale este parche.

¿Cómo desinstalo el parche?

En Windows, abre Control Panel  búsca por “Viewinstalled Updates”; haz clic en esta opción. Haz clic derecho en el parche de ArcGIS Pro 2.2 Parch 2(2.2.2) y da clic en desinstalar.

Si no tienes el parche previo instalado – ArcGIS Pro 2.2 Patch 1 (2.2.1)- puede ser descargado desde MyEsri.

¿Cuándo Esri corregirá este problema?

ArcGIS Pro 2.2 Patch 3 (2.2.3) estará dispobible en las primeras semanas de octubre, 2018, e incluirá el arreglo para este problema así como otras mejoras en el software incluidas en el parche 1 y 2.

 

Apoyo técnico GMT, Corp.

Anuncios

Parche de seguridad crítica de ArcGIS Server está disponible.

serverpatch

Esri descubrió una vulnerabilidad crítica en ArcGIS Server que causa una validación de control de acceso incorrecta cuando las solicitudes especialmente diseñadas se envían al servidor. Esto da como resultado que los servicios protegidos y sus datos estén expuestos a los usuarios cuando, de otro modo, no deberían tener acceso.

Esri ha hecho disponibles parches de seguridad para todas las versiones de ArcGIS Server en support actualmente entre la 10.2.1 y 10.6 en Windows y Linux. Si bien esta vulnerabilidad no ha afectado a usuarios, recomendamos encarecidamente a todos que apliques este parche dentro de las próximas dos semanas para minimizar el riesgo.

NOTAS:

  1. No acumulativo: a diferencia de la mayoría de los parches de seguridad de ArcGIS, este no es acumulativo, así que idealmente primero aplique todos los parches de seguridad compatibles para su versión. El uso de la utilidad de notificaciones de parches puede ayudar a facilitar este proceso. Este parche NO es dependiente de otros parches.
  2. Alcance: este problema afecta tanto a las implementaciones federadas como a los sistemas autónomos de ArcGIS Server y se ha solucionado en la versión 10.6.1.
  3. Mitigación: un firewall de aplicaciones web (WAF) que se ejecuta en modo de protección o utiliza el web adaptador IIS (no el web adaptor Java) puede reducir el riesgo de esta vulnerabilidad. Estas mitigaciones solo se deben considerar como soluciones de corto plazo hasta que se pueda instalar el parche de seguridad en el sistema.

Para descargar el parche haga clic aquí

Apoyo técnico GMT, Corp.

 

Error: Service Containing process crashed. Error: Could not initialize service ‘System/Publishingtools.GPServer’

Uno de nuestros clientes estaba enfrentando un error al tratar de publicar. Al momento de poner share as a service en ArcMap y publicar obtenía el siguiente error “Could not initialize service ‘System/Publishingtools.GPServer’

Una vez se detuvo el servicio desde el Manager, el servicio no volvió a correr dando el error ‘Service Containing process crashed for ‘System/PublishingTools.GPServer’.

VI2

Se identificó que el usuario estaba utilizando la versión de ArcGIS Server 10.4.1 y windows Server 2008 R2. Con estas características, se identificó el bug:

    • BUG-000110662 : Geoprocessing service instances crash after installing windows patches on Microsoft Windows Server 2008 R2 or Windows 7.

Este error se encuentra documentado por Esri en el siguiente enlace. Pare resolver el error , Esri hizo un parche de seguridad y debe instalarse para las versiones 10.2 hasta la 10.6.

Para descargar el ArcGIS Server Geoprocessing Service Starup Patch debe descargar e instalar el parche para la versión adecuada aquí.

Una vez descargue e instale el parche, espere un momento a que el servicio de ArcGIS Server reinicie y vuelve a dar clic para iniciar el servicio de publicación dentro del folder de sistemas en ArcGIS Server Manager.

Apoyo Técnico, GMT Corp.

 

Security Parch for Portal for ArcGIS 10.5.1

Capture

El primer parche de seguridad del año 2018 se ha lanzado para Portal for ArcGIS 10.5.1. Los parches para Portal for ArcGIS 10.4.1 y 10.3.1 se lanzarán en esta misma página, una vez estén disponibles.

Los parches de seguridad se lanzan para el último lanzamiento menor en una serie de productos de ArcGIS que aún se encuentran bajo Soporte Técnico.

Para descargar el parche haga clic en: Portal for ArcGIS Security 2018 Update 1 Patch

 

Apoyo técnico, GMT Corp.

 

ArcGIS Pro 2.0 Parche (2.0.1) está disponible

ArcGIS Pro 2.0.1 ya está disponible para su descarga. Se trata de un lanzamiento de revisión menor que aborda varios problemas de rendimiento y calidad. La próxima versión completa de ArcGIS Pro está programada para el final del año.

Una lista completa de los problemas tratados en ArcGIS Pro 2.0.1 se puede encontrar aquí.

Actualiza a ArcGIS Pro 2.0.1 accediendo a My Esri o usando el actualizador de software en la aplicación.

GMT Corp.

IMPORTANTE: Parches de seguridad para ArcGIS Server y Portal (2017 Update 1)

support

El primer conjunto de parches de seguridad para ArcGIS Server y Portal para ArcGIS del 2017 se acaba de publicar. Recomendamos a nuestros clientes que apliquen estos parches de manera oportuna. Para estar claro, existen parches de seguridad separados para ArcGIS Server y Portal para ArcGIS, y ambos deben aplicarse si está utilizando las versiones/software correspondientes, en este caso para la versión 10.4 o 10.4.1. Estas actualizaciones ya se han incorporado en la versión 10.5 de ArcGIS Server y Portal for ArcGIS pero es necesario instalar los parches para las versiones anteriores.

Referencias:

Portal for ArcGIS Security 2017 Update 1 Patch – Disponible para 10.4 y pronto para 10.4.1

ArcGIS Server Security 2017 Update 1 Patch – Disponible para 10.4 y 10.4.1

 

Apoyo Técnico, GMT Corp.

Parche para: Bug- ArcMap 10.4 and 10.4.1 crash when opening an MXD with data from a SQL Server enterprise geodatabase

Esri ha recibido una serie de informes de los clientes que ArcGIS for Desktop 10.4 y 10.4.1 (ArcMap) deja de funcionar al abrir un MXD con datos de una geodatabase corporativa basado en SQL Server. Los accidentes se han reportado que ocurren en ambos modelos de bases de datos simples y múltiples con SQL Server 2008, 2008 R2, 2012, y 2014. Este problema es específico de datos de geodatabases tienen datos mixtos de precisión como se explica a continuación.

NOTA: Este problema no se recrea ni impacta a clientes con otras bases de datos.

En ArcGIS 9.2, introdujimos el almacenamiento de coordenadas de alta precisión. Esta característica permitió a nuestros usuarios “migrar” sus datos de precisión básica existentes a datos de alta precisión. Cuando se ha migrado una capa, se puso un nuevo ID de referencia espacial, así como almacenar el ID de referencia espacial original como un ID de referencia secundaria, por lo que podría trabajar tanto con las funciones básicas y de alta precisión.

Como una mejora de rendimiento, con un 10,4 introdujimos un caché de esquema en donde, en lugar de utilizar metadatos para las capas individuales cuando se hace algo como abrir un documento de mapa (que se redujo el rendimiento para los usuarios que tenían miles de capas). Construimos un caché de todos los metadatos de las capas escaneando la tabla enteras SDE_layers.

El error que está causando estos incidentes (ERROR-000095750) está relacionado con el almacenamiento en caché la cadena secundaria del proyecto de la ID de referencia secundaria.

Los usuarios que crearon su geodatabase en SQL Server ArcGIS 9.2 o posterior generalmente no tendrán clases de entidad de precisión mixtos, y por lo tanto ninguna ID de referencia secundaria. La excepción es que todavía era posible después de ArcGIS 9.2 crear datos de precisión básicos mediante el uso de las API de SDE y algunas herramientas de línea de comando SDE.

Los usuarios pueden comprobar si este problema podría afectarles mediante la emisión de la siguiente consulta a su geodatabase:

select count (*) from sde.sde_layers

where secundary_srid is not null

Forma de arreglarlo

Se ha desarrollado  un parche ArcGIS 10.4.1 for (Desktop, Server) SQL Server Mixed Precision para resolver este problema. Recomendamos a los usuarios que utilizan SQL Server-based que han verificado que tienen un ID de referencia espacial secundario apliquen el parche al migrar a ArcGIS 10.4.1. Descargue e instale el parche de la siguiente dirección:  ArcGIS 10.4.1 for (Desktop, Server) SQL Server Mixed Precision Patch

NOTA: Este es solo para la versión 10.4.1 y no funcionará  con la versión 10.4.

Apoyo Técnico, GMT Corp